NIBObee/FAQ

Aus Nibo Wiki
Wechseln zu: Navigation, Suche


Fehler beim Linken

F: Beim Linken des Programms bekomme ich folgende Fehlermeldung:

C:\Programme\NIBObeeLib\lib\libnibobee_line.a(line.o): In function `line_readPersistent':
line.c:(.text.line_readPersistent+0x10): undefined reference to `__eerd_block'
C:\Programme\NIBObeeLib\lib\libnibobee_line.a(line.o): In function `line_writePersistent':
line.c:(.text.line_writePersistent+0x10): undefined reference to `__eewr_block'

A: Vermutlich verwenden Sie eine AVR Libc Version, die nicht zur NIBObeeLib Version passt. Für die nibobeelib-20091108 benötigen Sie WinAVR-20090313. Die aktuelle Version 1.2 (nibobeelib-20100424) arbeitet mit WINAVR-20100110 zusammen.



Stromverbrauch

F: Wieviel Strom verbraucht der NIBObee?

A: Der Ruhestrom des NIBObee liegt bei ca. 100 mA, die Motoren verbrauchen jeweils ca. 100 mA im Leerlauf und 200 mA bei Last (100%PWM)



Quellcode für den ATtiny

F: Wo finde ich den Quellcode für den ATtiny?

A: Der gesammte Quellcode ist im SVN Repository bei Sourceforge enthalten:



Fehlermeldung nach Treiberinstallation unter Vista

F: Ich bekomme nach der Installation des Treibers unter Windows Vista folgende Fehlermeldung:

Im Cache des Ressourcenladeprogramms ist kein MUI (Multilingual-User-Interface)-Eintrag geladen.

A: Das hört sich nach einem Problem in der Benutzerkontensteuerung (UAC) von Windows Vista an - sie sollte abgeschaltet sein - prüfen Sie dort die Einstellungen.



Keine Ladefunktion der Akkus möglich

F: Bei meinem NIBObee lassen sich die Akkus nicht laden!

A: Zum Laden der Akkus müssen sich die drei Jumper in der vorderen Stellung befinden und der Roboter muss ausgeschaltet sein!



Motorproblem

F: Bei meinem NIBObee dreht sich nur ein Motor / Bei meinem NIBObee dreht sich ein Motor nur in eine Richtung!

A: Überprüfe einmal folgendes:

  1. Sind alle Transistoren in der richtigen Orientierung eingelötet?
  2. Wurde jeweils der korrekte Transistor-Typ (BC-337 bzw. BC-327) in die jeweilige Lötstelle eingelötet?
  3. Sind bei den Lötstellen der Transistoren kalte Lötstellen zu finden? Evtl. nocheinmal vorsichtig nachlöten..
  4. Stecken von dem 74HC139 alle Beinchen korrekt im Sockel?
  5. Lötstellen des Sockels des 74HC139 prüfen und evtl. vorsichtig nachlöten..




Probleme mit dem Blue-Modul

F: Meine Smartphone-App verbindet sich nicht mit dem NIBObee / Blue-Modul!

A: Um die Bluetooth Verbindung mit dem NIBObee herzustellen geht man am besten folgendermaßen vor:

  1. NIBObee Demo App beenden
  2. Bluetooth am Handy deaktivieren
  3. NIBObee ausschalten
  4. NIBObee einschalten
  5. Bluetooth am Handy aktivieren
  6. NIBObee Demo App starten
  7. Verbinden: Zum Verbinden muss am Handy links unten die "Menütaste" gefunden und gedrückt werden. Diese „Menütaste“ sieht bei jedem Handy-Modell anders aus. Dann kann man auf den Knopf "Verbinden" drücken und aus der Liste der angebotenen Module das HC-06 Modul auswählen.

Windows 8 - Niborobolib kann nicht installiert werden

F: Unter Windows 8 bricht die Installation der Niborobolib mit der Meldung "Setup Wizard ended prematurely" ab!

A: Zur Fehlervermeidung muss die Treibersignierung abgeschaltet werden:

  1. Kommandozeile ("Ausführen") starten: Drücke "Windows-Taste" + "R"
  2. Dann "shutdown.exe /r /o /f /t 00" eingeben (spezieller Reboot)
  3. Im Menü auswählen "Problembehandlung" -> "Erweiterte Optionen" -> "Starteinstellungen" -> "Neustart"
  4. Nach dem Bootvorgang im Menü Taste "7" (Treibersignierung ausschalten) drücken
  5. Jetzt kann die Niborobolib problemlos installiert werden!
  6. Die geänderten Systemeinstellungen werden nach einem Neustart von Windows wieder automatisch zurückgesetzt

Keine Funktion nach dem Zusammenbau ohne erkennbare Lötfehler

Sowohl beim NIBObee, als auch beim Berry-AddOn sind vereinzelt Probleme bei den Batterieclips bekannt. Die verklemmten Bereiche an den Enden sind ggf. nicht stromführend verquetscht, so dass die Geräte nicht mit Strom versorgt werden.

Dies lässt sich einfach nachmessen, in dem man die anliegenden Spannungen prüft.

  • beim NiboBEE sollte an X8 bei eingelegten Batterien ca. 5V anliegen. Auch im ausgeschalteten Zustand.
  • bei der Berry-Platine sollte an X10 zwischen 1 und 4 eine Spannung von ca. 8V anliegen. Auch im ausgeschalteten Zustand.

Ein Nachlöten hilft hier leicht ab.

Aber Vorsicht! Auf jeden Fall die Akkus vorher entfernen, sonst werden die Clips durch den Federdruck und die Hitze beim Löten schnell irreparabel beschädigt!

nachgelötete Batterieclips