NIBObee/FAQ: Unterschied zwischen den Versionen

Aus Nibo Wiki
Wechseln zu: Navigation, Suche
Zeile 1: Zeile 1:
 
----
 
----
 +
===Fehler beim Linken===
 
'''F:''' Beim Linken des Programms bekomme ich folgende '''Fehlermeldung''':
 
'''F:''' Beim Linken des Programms bekomme ich folgende '''Fehlermeldung''':
 
  C:\Programme\NIBObeeLib\lib\libnibobee_line.a(line.o): In function `line_readPersistent':
 
  C:\Programme\NIBObeeLib\lib\libnibobee_line.a(line.o): In function `line_readPersistent':

Version vom 2. Februar 2015, 10:13 Uhr


Fehler beim Linken

F: Beim Linken des Programms bekomme ich folgende Fehlermeldung:

C:\Programme\NIBObeeLib\lib\libnibobee_line.a(line.o): In function `line_readPersistent':
line.c:(.text.line_readPersistent+0x10): undefined reference to `__eerd_block'
C:\Programme\NIBObeeLib\lib\libnibobee_line.a(line.o): In function `line_writePersistent':
line.c:(.text.line_writePersistent+0x10): undefined reference to `__eewr_block'

A: Vermutlich verwenden Sie eine AVR Libc Version, die nicht zur NIBObeeLib Version passt. Für die nibobeelib-20091108 benötigen Sie WinAVR-20090313. Die aktuelle Version 1.2 (nibobeelib-20100424) arbeitet mit WINAVR-20100110 zusammen.



F: Wieviel Strom verbraucht der NIBObee?

A: Der Ruhestrom des NIBObee liegt bei ca. 100 mA, die Motoren verbrauchen jeweils ca. 100 mA im Leerlauf und 200 mA bei Last (100%PWM)



F: Wo finde ich den Quellcode für den ATtiny?

A: Der gesammte Quellcode ist im SVN Repository bei Sourceforge enthalten:



F: Ich bekomme nach der Installation des Treibers unter Windows Vista folgende Fehlermeldung:

Im Cache des Ressourcenladeprogramms ist kein MUI (Multilingual-User-Interface)-Eintrag geladen.

A: Das hört sich nach einem Problem in der Benutzerkontensteuerung (UAC) von Windows Vista an - sie sollte abgeschaltet sein - prüfen Sie dort die Einstellungen.



F: Bei meinem NIBObee lassen sich die Akkus nicht laden!

A: Zum Laden der Akkus müssen sich die drei Jumper in der vorderen Stellung befinden und der Roboter muss ausgeschaltet sein!



F: Bei meinem NIBObee dreht sich nur ein Motor / Bei meinem NIBObee dreht sich ein Motor nur in eine Richtung!

A: Überprüfe einmal folgendes:

  1. Sind alle Transistoren in der richtigen Orientierung eingelötet?
  2. Wurde jeweils der korrekte Transistor-Typ (BC-337 bzw. BC-327) in die jeweilige Lötstelle eingelötet?
  3. Sind bei den Lötstellen der Transistoren kalte Lötstellen zu finden? Evtl. nocheinmal vorsichtig nachlöten..
  4. Stecken von dem 74HC139 alle Beinchen korrekt im Sockel?
  5. Lötstellen des Sockels des 74HC139 prüfen und evtl. vorsichtig nachlöten..